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Cure Excel’s Most Infuriating Habits – and Pick
Up Handy Spreadsheet Tips!

Like all the other programs in Microsoft Office,
Microsoft Excel is useful and powerful, but it also has all
sorts of ways to bamboozle you! In this article I’ll give
you solutions to Excel’s most irritating quirks and
oddities. I’ll also give you handy tips to help you use
Excel like a pro!
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This article shows you how to:
• Work around Excel’s most irritating behaviour
• Discover how to do things you didn’t know were

possible
• Create and use spreadsheets more quickly and

easily
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View Two Worksheets at the Same Time

Since a spreadsheet file can contain any number of
worksheets, it’s perfectly reasonable to want to refer to
one while working on another. Perhaps you want to copy
figures from the first sheet to the second, or perhaps you
just want to make sure the two sheets have a similar style
and layout.

You could switch back and forth between them by
clicking the tabs at the bottom of the window, but if you
have to do this for long it soon gets tiresome! Here’s a
better way: display the two sheets one above the other so
that you can see both at the same time.

With the required spreadsheet open in Microsoft Excel
(and either of those tabs selected), here’s what to do:
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1. Switch to the View tab on the Ribbon and click
the New Window button .

2. In Excel 2013 and later, another Excel window will
open looking exactly like the first and sitting in front
of it. Switch to the View tab of the Ribbon in this
window. (Alternatively you could switch back to the
first window, which is still displaying the View tab,
since it doesn’t matter which window you use to
carry out the next couple of steps.)

In Excel 2010, you won’t notice anything happen at
all, but don’t worry about that and carry on.

3. Now click the View Side by Side button .

4. Your two windows are now arranged one above the
other. At the moment both windows are showing
the same worksheet, so – in either window – switch
to the other sheet you want to see by clicking its tab.

5. You’ll notice that an option named ‘Synchronous
Scrolling’ has been switched on too: if you scroll up
or down in one window, the other will scroll in the
same direction by the same amount. You probably
don’t want that happening, so click the Synchronous
Scrolling button to switch it off.

Now you can get on and do whatever you needed,
referring to one of the sheets while typing into the
other. In fact, you can type into any sheet in either
window: you’re not limited to doing your editing in
just one of these windows. When you press Ctrl+S to
save your changes, you’re saving the changes made to
this file in either window.
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If you’d prefer to have two the windows side-by side
rather than one above the other, you can. Just click
the Arrange All button and choose Vertical followed
by OK in the little dialog that opens.

When you’ve finished using two windows and want to
go back to just one again, simply close either of those
windows. The remaining window will switch back to its
usual size and position.

Speed Up Your Work by Naming Important Cells

When you’re writing formulas to add totals and so on,
you can spend quite a time scrolling around to find the
cell references you need. For instance, perhaps you
need to add the figures at the bottom of your first
three columns, so you have to scroll down, determine
that they’re (say) A32, B19 and C26, then remember
those references as you type your formula:

=A32+B19+C26

Even worse, perhaps you’re totting-up figures from
different worksheets, so that as well as finding those
references you’ve got some unwieldy typing to contend
with:

=Sheet1!A32+Sheet2!B19+Sheet3!C26

Wouldn’t you prefer to type something like this
instead?

=TotalApril+TotalMay+TotalJune

It’s absurdly easy to do, and it brings all sorts of
benefits. When you’re writing formulas, it obviously
means you’ll be dealing with meaningful and
memorable names, so you’ll spend far less time looking
up cell references. And when you refer to an old
spreadsheet (or send one to someone else), those
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names will make it a lot easier to understand what’s
going on in your formulas.

Naming a cell is a simple two-step job:

1. Click the cell you want to name .

2. Click in the ‘Name Box’ at the far left of the formula
bar, which currently shows that cell’s reference
and in its place type whatever name you choose for
the cell . Press Enter to confirm it and you’ve
finished.

There are a few rules about what names you can
choose, but they’re fairly straightforward. A name
must start with a letter or an underscore character (_),
not a number, and it mustn’t contain spaces. You can
use a mix of capital and small letters, but Excel doesn’t
take any notice of the difference, so if you name a cell
TotalApril but refer to it as totalapril in a formula,
that won’t cause a problem.

Excel Isn’t Updating My Totals!

For most of us, an important benefit of using a spread-
sheet is the way it automatically updates our totals
whenever we add or change figures. For example,
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taking the figures in the screenshot on the previous
page, if I added 1 to the number in cell A4, I’d expect
the total in cell A6 to increase by 1 automatically.

Surprisingly, though, Excel doesn’t have to work that
way. If you’d prefer that Excel didn’t update your
formulas whenever figures changed, you can tell it not
to. In that case, it would update them only when you
opened a spreadsheet file, to make sure everything is
shown correctly when you first see the figures.

You probably wouldn’t do this on purpose, and it’s not
easy to do it by accident, but it can happen of its own
accord, and it’s one of Excel’s worst annoyances. All it
takes is for you to make a mistake severe enough that
Excel doesn’t know how to deal with your formulas,
and you can find that it simply stops dealing with them!

If you suspect this is what has happened, a good first
step is to change a figure somewhere which you’d
expect to cause a formula-cell to update. If it doesn’t
update, press the F9 key, which tells Excel to recalculate
all the formulas in the sheet.

Assuming that works, and that formula-cell now shows
the figure it should, follow the steps below to switch
automatic calculation back on.

If it didn’t work, and you instead saw an error mess-
age, you’ll first need to find and fix whatever problem
there is with your formulas that’s preventing Excel
from recalculating them successfully.

If all else fails, try an elimination process of deleting
one formula-cell and pressing F9 to see if that was the
formula causing the problem. If it wasn’t, press Ctrl+Z
to reinstate that formula and repeat the process with
another.

1. Click the File tab at the far-left of the Ribbon and
choose Options.
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2. At the left of the Options window, click on Formulas
.

3. On the right, below the words Workbook
Calculation, you’ll probably find that the ‘Manual’
option has been selected: in other words, Excel has
indeed stopped recalculating your formulas
automatically and will only do it when you press the
F9 key. Click the Automatic option to select it .

4. Click the OK button at the bottom of the window to
close it and return to your spreadsheet.

Avoid Losing Zeros at the Beginning or End
of Figures

A common frustration for spreadsheet newcomers is
Excel’s apparent dislike of zeros:

• You type a telephone dialling code (such as ‘01234’)
into a cell, and the moment you leave that cell it loses
its leading zero (‘1234’).

• You type a decimal number into a cell (such as
’22.50’), and Excel promptly removes that trailing
zero (’22.5’).
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There’s a good reason for this, and it’s the same in both
cases. As far as Excel is concerned, the zeros are unnec-
essary. However, the solutions are different.

Leading zeros

In the first case, Excel doesn’t know you intended to
type a dialling code. It looks like a number (1234), so
Excel treats it that way and strips out the irrelevant zero.

One solution is to type an apostrophe immediately
before the number ('01234). This tells Excel to treat
what you’ve typed as text, not as a number. When you
leave the cell, the apostrophe will be removed but the
number itself won’t be changed.

Alternatively, if you need to type a row or column of
similar items, select that row or column and choose Text
from the drop-down list in the ‘Number’ group on 
the Ribbon.

This leads to another little annoyance: if a cell contains
a number but it’s being treated as
text, that cell gains a little green
triangle as a warning. It’s simplest
to ignore these triangles, but if they offend you, it’s
possible to get rid of them. Go to File > Options,
choose Formulas at the left of the Options window
and then, in the ‘Error checking rules’ section, remove
the tick beside Numbers formatted as text or
preceded by an apostrophe. Click OK and those green
triangles will disappear. 

Trailing zeros

In the second case, you probably intended the figure to
represent currency (£22.50), so you need to keep that
final zero for clarity, or perhaps you want Excel to show
all the figures in this column to two decimal places so
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that the decimal points all line up and the figures are
easier to read.

If you intended the cell to represent currency, select the
cell (or the entire column or row), open the drop-down
list in the ‘Number’ group on the Ribbon and choose
either Currency or Accounting. (The two are almost
identical, but ‘Accounting’ places the £ sign at the left of
each cell whereas ‘Currency’ places it beside the figure.)

If you want to show the figure to two (or more) decimal
places, select the cell (or the entire row or column),
choose Number from the drop-down list in the
‘Number’ group and then click the Increase Decimal
button as often as needed to increase the number of
decimal places.

Type Two or More Lines of Text into a Cell

If you’ve ever tried to type more than a single line of
text into a cell, you probably gave up, assuming it was
impossible. The obvious thing to do is to press Enter at
the end of the first line – but, of course, that just takes
you to the cell below rather than starting a new line in
the current cell.

The trick is to press Alt+Enter instead. By doing this, you
can type as many lines of text into a single cell as you
like.

1

2

25April 2022

Format as Currency
or Accounting…

Instead, use
Alt+Enter

Excel: Tips to Fix Common Annoyances 

Pressing Enter
won’t start a
new line

… or use the
Increase Decimal
option

2

1

PCS_4_APRIL_2022_E926_18pp_mrg  20/01/2022  16:33  Page 25



E 926/10

There’s a catch, though, as you’ll discover when you do
it. Initially everything seems fine: you type the first line,
press Alt+Enter and type the second line, and it all looks
as it should . However, when you press Enter or Tab
to leave the cell, you’ll find that Excel doesn’t widen the
column to fit those two lines of text – it just makes the
row tall enough to contain all the characters .

To make the text look presentable, you have to widen
the column yourself. Move
the mouse pointer up to
the join between the
current column and the
column to its right ,
press-and-hold the left
mouse button and drag to
the right until the column is wide enough to display the
text as you intended.

Even then, it probably doesn’t look perfect. You’ll
usually find that the cell is still much taller than it needs
to be, with your text at the bottom below an expanse
of white space.

To fix that, click your cell and then click the Top Align
button in the ‘Alignment’ group on the Ribbon’s
Home tab. As well as aligning your text to the top of
the cell, it also removes the unnecessary white space in
that cell, making it look the way you probably hoped it
would from the start!
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Combine Different Formatting in a Single Cell

You’ve typed a heading into a cell and you want to
make it bold. Easy – just click that cell and press Ctrl+B
(or click the ‘B’ button in the ‘Font’ group on the
Ribbon). Ideally, though, you’d also like to make a
couple of words italic. Surely Excel won’t let you do
that?

Remarkably, it will. Just click the cell, so that its text
appears in the formula bar, then select the characters
you want to format and use the familiar options in the
‘Font’ group on the Ribbon. 

In this way, the text in a single cell can use any
combination of fonts, sizes, styles and colours.

27April 2022

Make just a couple
of words italic

Excel: Tips to Fix Common Annoyances 

4

Easy: select those
words in the
formula bar

PCS_4_APRIL_2022_E926_18pp_mrg  20/01/2022  16:33  Page 27



E 926/12

Prevent Your Spreadsheet Printing at a 
Tiny Size!

One of the most common annoyances with Excel is the
way spreadsheets are printed. Without warning, you
can find that a particular worksheet is printed at a tiny
size, with all your figures bunched into one corner of an
otherwise empty page.

Why does it do that? Well, it’s quite likely that
somewhere on that worksheet (far to the right, and/or
a long way down) there’s a cell that Excel regards as
non-empty: perhaps you did actually type something
into it, but you might simply have left it empty but
formatted it in some way. Whatever the reason, Excel
assumes you want to include that cell in the printed
copy, so it scales everything down to a size that will fit
all your cells (including that one) on an A4 page.

You could go in search of that cell and try to delete
whatever it contains, but there’s a simpler way. You can
set a ‘print area’ for the sheet so that anything outside
that area will be ignored. Here’s what to do:

1. Start by selecting the cells you do want included
when you print the worksheet. Click in the top-left
cell you’ve used and, keeping the mouse button
pressed, drag diagonally downwards and to the
right until you reach the last cell you’ve used, then
release the mouse button.

2. Switch to the Page Layout tab on the Ribbon, click
the Print Area button and choose Set Print Area.
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3. Now you’re ready to print, safe in the knowledge
that only the cells you’ve selected will be printed.
Press Ctrl+P (or choose File > Print) and have a look
at the preview of the printed page to make sure it
looks as it should. If the preview suggests that your
paper copy will still look rather cramped, there are
several changes you can make to the print settings
that could improve matters:

• If the collection of cells you’re printing is wider
than it is tall (i.e. many columns, few rows), open
the dropdown list that currently shows ‘Portrait
Orientation’ and choose Landscape Orientation
instead, to print the cells widthways on the paper.

• Try reducing the size of the margins of the page,
providing a greater printing area. Open the drop-
down list that currently shows ‘Normal Margins’
and choose Narrow, or choose Custom Margins
and enter your own figures for the four margins
in the Page Setup dialog that opens.

• Choose whether your cells should be printed on a
single page or would be better spread over
several pages. Open the drop-down list that
currently shows ‘No Scaling’ and you’ll find
options to fit the whole print area onto a single
page, fit all columns onto one page, or fit all rows
onto one page.

4. Finally, when you’re happy with the way the
preview looks, click the Print button at the top-left
of the window to print the result on paper.

The ‘print area’ you set will be stored with your spread-
sheet when you save it, so the same area of this sheet
would be printed next time if you print it again. If you
ever add more rows or columns to this sheet (and
intend those to be printed), be sure to repeat the first
two steps above to set the new print area before
trying to print.
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Better than a Calculator: Add Figures Fast!

Perhaps you’re booking a holiday and you want to check
the total cost of all the elements. You could use a
calculator, but there’s a better way – use Excel!

Start Excel (and, in Excel 2013 or later, choose Blank
workbook from the Start screen), then type your figures
one after the other into a single column (pressing
Enter after each figure to move to the cell below and
type the next). When you’ve entered them all, select
those cells (by pressing the left mouse button in the top
cell and dragging down until you reach the last). 

Now look at the bottom of the window and you’ll
see that Excel tells you what you want to know. Along
with ‘Average’ (the mean value you’ve typed) and
‘Count’ (the number of cells you’ve selected), it shows
‘Sum’, which contains the total of those cells added
together.

Using Excel to do this takes much the same time as it
would take to use the Windows Calculator program to
do it, but it gives you several advantages. First, it’s easy
to check that you’ve typed every figure correctly – so
you know your total really is accurate – and that you
haven’t missed out a figure. Second, you can quickly
remove a figure by holding Ctrl and clicking its cell to
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see if you like the total better without it, or type a
different figure into one of the cells and then reselect
them all to see the new total.

And, of course, you’re not really creating a spreadsheet
as such, or even bothering with formulas. When you’ve
received the answer you needed, you just close Excel
and say No to the question of saving the file.

Speed Tip: Set Up Multiple Worksheets 
at Once

When you’re creating a spreadsheet for accounting
purposes, it’s often going to consist of several sheets:
perhaps one for each month of the year, or a sheet per
quarter. You probably want those sheets to be laid out
identically to one another, with the only difference
being the figures you’ll enter in the future.

In other words, you’ll probably want the same column
headings on each sheet, formatted in the same way;
you’ll want to format certain columns as ‘Currency’, or
‘Short Date’ or ‘Text’ because that’s what they’ll
eventually contain; you’ll want to widen certain columns
because they’ll contain descriptions rather than
numbers; you might even like to insert formulas lower
down the sheet that will tot-up the figures you’ll later be
entering further up.

The trick in this situation is to plan ahead. You don’t
have to set up those sheets individually, and you can
obviously save yourself a lot of time and frustration by
doing all this work just once!

Starting by deciding how many sheets you’ll need – 12
for a month-by-month spreadsheet, for example, or 4
for a quarterly one – and then create that number of
sheets. You already have one sheet in Excel 2013 and
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later, or three in Excel 2010, so press Shift+F11 as often
as needed, adding one new sheet each time.

Next, right-click one of
your tabs, it doesn’t mat-
ter which, and choose
Select All Sheets from
the context menu. The
tabs all turn white to
indicate they’re selected. 

Now, on the sheet in
front of you, start setting
things up the way you
want them, including everything that should appear on
every sheet, and because every sheet is selected they
really will all look the same.

If you want to check that this really is working, just
click one of the other tabs to have a look. Just
remember that doing this will deselect all the other
sheets, so when you’re ready to continue working on
them all, you’ll have to reselect them with a right-click
> Select All Sheets first.

Easily Edit Cells Without Using the
Formula Bar

When you click a cell and start typing, you always
replace what was in that cell before. So how can you edit
a cell – add something extra to it or correct a
misspelling?

You’d be forgiven for thinking you have to click the cell
and then make any necessary changes in the formula
bar. You can do it that way, but it’s easier to do your
editing in the cell itself, using either of these methods:
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• Double-click the cell.

• Select the cell and then press the F2 key.

The only difference between the two is that when you
press F2 the text cursor always appears at the right of
the cell’s text, whereas when you double-click it appears
roughly where the mouse pointer is.

You can then make any changes you need right in 
the cell itself, much as you edit text in any other
program. Afterwards, press Enter or Tab or just click in a
different cell.

The Arrow Keys Have Stopped Working

Here’s a problem that’s more-or-less unique to Excel, and
it can be a real puzzle. You want to use the arrow keys
to move the cell selector box around on your sheet, but
they don’t do that.

Instead, pressing an arrow key causes your worksheet to
scroll in that direction. For example, pressing the down-
arrow key in the expectation of selecting the cell below
the current one just causes the sheet to scroll down by
one line. What’s happened?

The answer is that you’ve accidentally pressed the Scroll
Lock key. You’ll find it towards the top-right of your
keyboard, near the Print Screen and Pause|Break keys,
and this is the effect it has in Excel. The solution, of
course, is to press it again to switch it off.

Most programs take no notice at all of this key, but it
behaves like Caps Lock: once switched on, it stays on
until you toggle it off again. So you might well have
caught the Scroll Lock key hours ago, but you wouldn’t
have noticed anything unusual until you started Excel
and tried to use the arrow keys!
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Quickly Insert Blank Rows or Columns

Here’s one final annoyance, although it’s more likely to
be an annoyance with yourself rather than Excel! You’ve
added row after row of data – perhaps a series of
payments in date order – and then realised you’ve missed
a few that should appear halfway down the sheet.

What can you do? Well, it’s easily fixed. Let’s say you
need one blank row added above row 10. Just move the
mouse to the left of the cells, where the row numbers
appear, right-click on the 10 and choose Insert from the
context menu. Everything from row 10 downwards
moves down by one row, giving you a blank row at 
row 10.

What if you needed two or three rows there, rather than
just one? Well, you could do exactly the same again (and
again, and again…), but if you already knew you needed
three rows, there’s a quicker way than we used above.
Move the mouse pointer to the 10, press-and-hold the
left mouse button and drag down until you reach the 12.
You’ve now highlighted three rows (10, 11 and 12).
Right-click one of those highlighted row numbers and
choose Insert: now everything moves down by three
rows, giving you three blank rows from row 10.

If you need to insert columns rather than rows, the
steps are exactly the same, except that you’ll be
working with the column letters at the top of the grid
rather than row numbers at the left.

So what does this do to your formulas? If you had a
formula adding A10 and B10 together, for example, and
you inserted a row further up, they’ve now become A11
and B11. The answer is: nothing at all! Excel will
automatically adjust any formulas affected by the
change to ensure they still do what they’re supposed to.
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