
Optimise Your Browser’s Security to Protect 
Your Whole Windows System 

There are many great browsers available for Windows these days, such as
Chrome, Edge and Firefox. With all of these options, it is important that you take
steps to make sure that your browser is set up safely, since it acts as a direct link
between your PC and the dangers lurking on the Internet. 

You can only properly protect your computer from dangers and unauthorised
access if your browser is safe. 

In this article, I’ll show you the steps you need to take to ensure that your browser
stays secure, both at home and when you are on the road.

15

Using the information given in this article you will be able to:

� Safely configure Java or better still, disable it altogether,

� Reset your browser back to its factory settings,

� Use the HTTPS protocol to protect data you send over the Web.
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Browser Security: Safe Internet Surfing
with the Right Settings 
When you surf the Web, you expose yourself to various
dangers. Your browser effectively acts as a gateway to the
Internet, but the gateway is two-way, and can allow hackers
to access your computer by exploiting weaknesses. New
security gaps are constantly being found in browsers, and
the developers just can’t keep up with them, trying to plug
the gaps with security updates. The methods that
cybercrooks use to attack systems varies over time too.
Whereas Phishing attacks used to be the hackers favourite
means of attack, nowadays they seem to prefer Trojans to
get at your confidential data. 

Browser developers respond by releasing new versions of
their browsers, which offer improved security compared to
older versions, so the first basic rule of browser security is: 

•   Always install the latest available version of your browser. 

The second basic rule is related to this:

•   Always install all of the available security updates for your
Windows system using the Windows Update function. 

How to Keep Your Browser as Up-to-date
as Possible 
By default, your browser is configured to have all of the
latest security updates installed automatically, as they
become available. However, the feature doesn’t always work
flawlessly. For this reason, you should check for updates for
your browser manually, at least once a month (unless you
use the Edge browser on Windows 10, where the process is
fully automatic). 

Hackers attacks
are becoming
increasingly
refined

Follow these two
basic rules

Regularly check
for updates 
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If you use Internet Explorer, proceed as follows: 

If you use Mozilla Firefox to surf, proceed as follows: 

Internet Explorer 

Firefox

Chrome

:1.   Press + , type control /name Microsoft.
WindowsUpdate and click OK.

2.   Use the Windows Update tool to check for any
available updates for your system and install them. 

R

If you use Google Chrome, proceed as follows: 

1.   Google updates its browser automatically. Open the
Google browser and click on the three-dot icon in
the top right-hand corner. 

:

:

1.   Open the Firefox browser. 

2.   Click on the three-line icon in the top right-hand
corner, then click on Help.

3.   Click onto About Firefox and Firefox will imme-
diately begin to search for new updates. 

After a major Firefox update is installed, it is usually
necessary to restart the browser

Click here to install
the update

The current version
is shown here
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Always keep
Windows as 
up-to-date as
possible

Updating
Windows
10/8.1/7

Updating
Windows 10 

2.   Click Help > About Google Chrome and the browser
will search for available updates for your system. 

Don’t Neglect Updating Windows 
and Your Applications 
You should always install the new security updates for your
system as soon as Microsoft release them, and also install
updates for your applications to close security gaps. Widely
used programs such as Java are often targeted by hackers,
and the developers of those programs release updates to
close up security gaps, sometimes not quick enough. 

Microsoft delivers the latest fixes for Windows using a
feature that is built-in to the operating system. Windows
Update searches for and downloads the latest fixes for your
Windows system, as well as other Microsoft products. 

How to perfectly configure the Windows
Update function

You can use the Windows Update feature built-in to the
Control Panel on Windows 8.1 and 7, to configure how updates
are installed. On Windows 8.1, press + , then click on
Control Panel > Windows Update. On Windows 7, click on
Start, then click on Control Panel > Windows Update. 

Clicking on Change settings allows you to choose when
updates are installed on your system.  You can click on
Check for updates to search for available updates on your
system. The tool will then check for and install any updates
that you haven’t yet installed. 

If you use Windows 10, there are different ways of con-
figuring the update component, based on which Windows
10 edition you have. 

X
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Reduce the Risks Posed by Java 
to a Minimum 
Hackers don’t just attack your browser and Windows
system. Other programs that work with your browser can
also have dangerous security gaps. Hackers are well aware
of these gaps and know how to misuse them in order to
infiltrate your system. 

On Windows 10 Home, you are given hardly any options to
configure how updates are applied. In Windows 10 Pro, first
open your Settings App and then click on the Update &
Security option.

Click onto Advanced options. 

Safeguard your Windows system with these settings

Configure which
updates are
delivered here

Use this option to
temporarily pause
updates on
Windows 10
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1.   Click on the Java Control Panel icon in the taskbar
or in the Control Panel. 

2.   Click on the Security tab, and untick the option
Enable Java content in the browser. 

3.   Click OK. 

Java is one of the most dangerous programs and installed
on almost every PC. In order to keep Java up-to-date, click
on the Java Control Panel icon in your taskbar, click on the
Update tab, then click on Update now. 

My recommendation: if you don’t need Java, disable it com-
pletely. Fewer software developers and websites are relying
on Java these days, so you can probably do without it: 

If you do need to use an application that relies on Java, then
you need to keep the following security points in mind: 

•     Empty the Java cache: If you empty the Java cache,
your browser has to download a required Java
application when opening a website. Information about
your surfing habits will also be deleted. To delete the
Java cache, open the Java Control Panel and click on
the General tab. Click on Settings under Temporary
Internet Files and untick the option to keep temporary
Internet files on your computer. 

•     Activate important security settings: Increase your
protection by applying these security settings. Open the
Java Control Panel, click on the Advanced tab and
activate the settings shown in the screenshot on the
next page:

…or better still,
disable it

Important Java
security settings

:

Update Java…
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•     Activate ‘click to play’ in your browser: The click to
play function minimises the risk of you accidentally
running Java content in your browser. When this is
enabled, Java content will only be executed if you click
on it. This option is available in all browsers except
Edge. Mozilla Firefox: type about:config into the
browser’s address line and accept the warning message.
Look for and double-click on plugins.click_to_play and
set the value to true. Google Chrome: In the address
bar, type in the following command: chrome://settings
/content and press . In the content settings,
scroll through to the bottom and activate Unsandboxed
plugin access > Ask when a site wants to use a plugin
to access your computer (recommended). Internet
Explorer: click on the cog icon and select Manage
Add-ons then disable the Java add-on. 

Enter

Use these settings to be safe with Java 
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Activate Your Browser’s Privacy Mode to
Boost Protection while Surfing
Almost all browsers offer a private mode that you can use
to force your browser to store less tracking information on
your PC between Internet sessions. 

When in private mode, no browsing history is recorded, no
cache is saved to your hard drive and no cookies are saved. 

Proceed as follows to switch to private mode: 

Internet Explorer: click on the cog icon in the top right-
hand corner and choose Safety > InPrivate Browsing, or
press + + .  When you close the InPrivate
window, all cookies will be deleted. 

Edge: click on the three-dot settings icon and select New
InPrivate window, or press + + .

Firefox: click on the three-line icon in the top right-hand
corner, then click on New Private Windows. 

Google Chrome: click on the three dot icon in the top right-
hand corner and choose New Incognito window. 

Enter

Enter

Ctrl

Ctrl

P

P

Optimal Protection with the Right Internet
Security Settings
Hackers are increasingly resorting to more refined methods
to steal your data, meaning that you can only really protect
yourself by applying the correct security settings in the first
place. I’ll show you the settings you need to protect yourself. 

Every browser has its own security settings which you
should check. This is how you can find them: 

•     In Internet Explorer click on Tools > Internet options
> General (press if the Tools menu isn’t shown).
Click on the Security tab and check the settings shown. 

Alt
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Practically
anonymous
surfing

Internet Explorer

Edge

Firefox

Chrome

Important
security settings
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•     In Edge, click on the three dots in the top right-hand
corner of the browser and click Settings. Scroll down
the window and click on View advanced settings.
Check the settings under Save passwords option in the
Autofill section. 

•     Click on the icon showing three lines in the top right-
hand corner of Firefox and choose Options then click
on the Privacy & Security tab and check the settings. 

•     Click on the icon showing three dots in the top right-
hand corner of Chrome and choose Settings. Next,
click on Advanced and then check the settings under
Privacy and security.  

In order to boost the privacy of the Internet Explorer
browser, you should also check the security level settings in
the Internet Options Control Panel. 

The Windows Internet security settings
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Settings in the
Control Panel 

Zone Description

Enter sites into this zone which you want to visit but
which have dubious security (mobile phone ringtone
download sites which display lots of pop-ups, for
example). 

All web pages that you visit that are not assigned to a
particular zone will automatically be assigned to this zone. 

Any site that you visit on your local network will be
assigned to this zone.

You can add sites to this zone that you know to be safe to
visit and which require lower security settings in order to
display particular types of content.

Restricted Sites

Internet

Local Intranet

Trusted Sites
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Internet
Explorer, Edge,
Firefox and
Chrome

If you set the Internet zone to Medium High it gives you a
good balance between security and usability. This should be
the default setting, but make sure it hasn’t been changed. 

My tip: The security level of the Trusted Sites zone can be
set to a lower level (Medium or Low). Add all websites that
you trust and which need access to advanced browser
features (your online banking site, for example) to this zone. 

How to Reset Your Browser Back to its
Factory Settings
If you encounter browser problems, or you are concerned
about your computer’s security, you can reset your browser
back to its default settings. Doing so will disable all add-ons
in your browser, removing potentially unwanted software.
The following table shows you how to reset the four most
popular browsers: 

Browser Procedure

To reset Internet Explorer back to its default settings,
proceed as follows:

Press the key and click Tools > Internet options. In
the Internet Options window, click on the Advanced tab.
Click on the Reset button, then follow the prompts on
screen to reset your browser. 

To reset Edge back to its default configuration, click on the
three dot icon in the top right-hand corner, then click on
Settings > Choose what to clear.

Select the options Media licences, Browsing history,
Cookies and saved website data, Cached data and files,
Tabs I’ve set aside or recently closed and Website
permissions, then click on Clear. 

Alt

Internet
Explorer 

Edge
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Remove
unwanted
toolbars

Safely Remove Unnecessary Toolbars 
and Programs 
Just one wrong mouse click is more than enough to have
unwanted software installed on your computer. The best
thing to do is remove the unwanted tool immediately, or at
least as soon as you notice that something has been in-
stalled. You can do so using the steps presented below. 

1.   On Windows 10/8.1 open the Control Panel by
pressing + , type control and click OK. In
Windows 7 click on Start > Control Panel. 

R
:

Browser Procedure

To reset Firefox back to its default settings, simply
proceed as follows:

Click the three-line icon in the top right-hand corner of
the window, then click the help icon. From the Help
menu choose Troubleshooting Information. Click the
Refresh Firefox button in the upper right-hand corner
of the Troubleshooting Information page, then click
Refresh Firefox in the confirmation window that opens.

In Google Chrome click on the three-dot icon in the top
right-hand corner of the window and select Settings,
then click on Advanced. 

Scroll to the bottom of the screen, then click on Restore
settings to their original defaults. Click on Reset
Settings to complete the process. 

Firefox

Google Chrome
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If the toolbar isn’t listed, you can remove it directly from
your browser. If you use Edge: 

2.   Set the View by drop-down menu to Large icons on
the top right-hand corner, then click on Programs
and Features.

3.   You will then see a list of all of the software that is
installed on your system. Select the toolbar that you
want to uninstall and click on Uninstall in the menu
bar along the top of the window. 

1.   Click on the three-dot icon in the top right-hand
corner and choose Extensions. 

2.   Set the extension that you want to disable to Off. 

If you have Firefox, proceed as follows:

1.   Click on the three line icon in the top right-hand
corner then click on Add-ons.

If you have Internet Explorer, proceed as follows:

1.   Open the Internet Explorer, and click on Tools >
Manage add-ons. If the Tools menu isn’t shown,
press the key. 

2.   Using the Show drop-down list, select All add-ons. 

3.   In the list of available add-ons, select each add-on
in turn then click on Disable.

4.   Once you have deactivated all the add-ons that you
don’t need in the list, click on Close.

Alt

:

:

:
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Difference
between HTTPS
and HTTP

HTTP = not
encrypted

In Google Chrome, you can disable add-ons as follows:

1.   Click on the three dots icon in the top right-hand
corner of the Chrome window, next to the address
bar.

2.   Click More tools and then onto Extensions when the
menu opens. 

3.   Select each add-on in turn then click on the Remove
button to the right of it. 

4.   Confirm the uninstallation by clicking on Remove.

2.   In the Add-on manager, work through the add-ons
listed in the Extensions tab.

3.   Select each add-on in turn and then click on the
Disable button.

4.   Save the changes by clicking on OK.

:

Connect with the Secure HTTPS Protocol
wherever Possible
HTTP stands for HyperText Transfer Protocol. It is the
communications language the PCs and web servers use to
transfer website data, such as text and images. 

Basic HTTP transfers move data without first applying
encryption. This means that potentially anyone on the
Internet could intercept the data and read it, similar to
sending a postcard that could be read by the postman. 
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The HTTPS protocol encrypts the data that it transfers. The S
at the end of the name stands for secure, meaning that data
transferred using this protocol is protected, and also allows
your browser to check the validity of your web server too.

All browsers support the HTTPS protocol to communicate
securely with web browsers. Unlike an unsecure HTTP
connection, you can recognise a secure HTTPS connection
thanks to the lock icon shown in the address bar. 

Whenever you need to transfer your personal data, such as
when you are banking online, you should use a safe HTTPS
connection. Hopefully the web server you are accessing will
automatically direct you to the safe website when you type
the site’s name, but if this doesn’t happen try typing the
letters https:// in front of the website’s address. This will
ensure that if a secure connection is available it will be used. 

Online criminals will always try to steal your data or money.
As long as new security gaps are discovered, there will
always be hackers that will try to abuse these gaps. You
should therefore safeguard your browser using the tips and
tricks from this article, making life difficult for the criminals!

HTTPS =
encrypted

HTTPS is
supported by all
browsers

Summary

An unsafe connection

The lock icon shows this connection is secure 
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